Решить на паскале: 1) Написать программу для ввода n пар натуральных чисел, из которых выбрать максимальное значения из каждой пары и посчитать сумму максимальных значений. На экран вывести список выбранных значений и сумму. Программу написать с использованием функции.
2) Написать программу подсчета количества четных и нечетных цифр 10 значного натурального числа. Программу написать с использованием процедуры, принимающей и возвращающей значения.
3) Написать программу для определения, является ли треугольник прямоугольным по трем введенным значениям длин его сторон. Программу написать с использованием процедуры без явного ввода значений и вывода (возврата) результата из процедуры .
4) Написать программу для ввода n пар чисел, из которых выбрать максимальное значения из каждой пары и посчитать сумму максимальных значений, при том так, чтобы четность суммы совпадала с четностью большинства выбранных чисел. (Если четность не совпадет, то выбрать число другой четности из пары с минимальной разностью значений). На экран вывести количество четных и нечетных чисел и максимальную сумму.
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
Writeln('k=',ArrRandom(15,1,20).Println.Count(x->x>10))
end.
Тестовое решение
4 16 14 9 11 18 17 14 14 15 1 1 9 10 15
k=9
2. А вот так учат решать в школе...
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
var
a:array[1..15] of integer;
i,k:integer;
begin
Randomize;
k:=0;
for i:=1 to 15 do begin
a[i]:=Random(20)+1;
Write(a[i],' ');
if a[i]>10 then k:=k+1
end;
Writeln;
Writeln('k=',k)
end.
Тестовое решение:
18 15 7 6 3 3 10 6 6 15 2 16 16 2 12
k=6
Вариант №1:
text = input("Введите какойто текст: ")
if len(text) == 1:
print("В тексте", '"' + text + '"', len(text), "символ")
elif len(text) == 2 or len(text) == 3 or len(text) == 4:
print("В тексте", '"' + text + '"', len(text), "символа")
else:
print("В тексте", '"' + text + '"', len(text), "символов")
Вариант №2:
text1 = input("")
text2 = input("")
text3 = input("")
print('')
print("Строка №1 " + str(len(text1))) # or print("Строка №1", len(text1))
print("Строка №2 " + str(len(text2))) # or print("Строка №2", len(text2))
print("Строка №3 " + str(len(text3))) # or print("Строка №3", len(text3))