В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lsllalap
lsllalap
28.03.2022 08:53 •  Информатика

Решить ! информатика. 10 класс. написать программу, которая выводит таблицу значений функции у =|х - 2| + |х + 1|. диапазон изменения аргумента - от -4 до 4, шаг приращения аргумента — 0,5. составить программы тремя циклами ( 1. цикл предусловие, 2. цикл постусловием(цикл "до"), 3. цикл с параметром("for"

Показать ответ
Ответ:
meskov
meskov
22.03.2022 12:47
#include <stdio.h>

int main() 

   int n;
   printf("n = ");
   scanf("%d",&n);
   int a[n];
   int b1=1, b2=1;

    for (int i = 0; i<n; i++) {
    printf("a[%d] = ", i);
    scanf("%d", &a[i]);
  }
   for (int i=0; i<n-1; i++) {
    b1 = b1 && (a[i+1]>a[i]);
      b2 = b2 && (a[i+1]<a[i]);
    }
    if (!(b1 || b2))
     for(int i=3;i<n;i+=4) {
      for(int j=i;j<n-1;j++) a[j]=a[j+1];
      n--; i--;
     }
   for (int i=0; i<n; i++)
    printf ("%3d  ", a[i]);
   printf("\n");        return 0;
}

Пример:
n = 15
a[0] = 12
a[1] = 16
a[2] = 19
a[3] = 20
a[4] = 24
a[5] = 28
a[6] = 31
a[7] = 33
a[8] = 35
a[9] = 40
a[10] = 46
a[11] = 50
a[12] = 55
a[13] = 57
a[14] = 60
12 16 19 20 24 28 31 33 35 40 46 50 55 57 60
0,0(0 оценок)
Ответ:
gnezdozatokaиванка
gnezdozatokaиванка
17.02.2022 09:15
Для того, чтобы ответить на данный вопрос, необходимо разобрать каждое устройство:

1) а. мышь - устройство для ВВОДА информации.
2) б. клавиатура - устройство для ВВОДА информации.
3) в. джойстик - устройство для ВВОДА информации.
4) г. плоттер - устройство для ВЫВОДА информации.
5) д. сканер - устройство для ВВОДА информации.
6) е. принтер - устройство для ВЫВОДА информации.
7) ж. монитор - устройство для ВЫВОДА информации.
8) з. акустическая система - устройство для ВЫВОДА информации.

Теперь все устройства разделим на две группы:
1) Устройства для ВВОДА информации:
- а. мышь.
- б. клавиатура.
- в. джойстик.
- д. сканер.

2) Устройства для ВЫВОДА информации:
- г. плоттер.
- е. принтер.
- ж. монитор.
- з. акустическая система.

Мы смогли определить устройства для ввода и вывода информации и поэтому теперь можно определить правильный ответ.

Правильным ответом является пункт 1) г, е, ж, з.

ответ: 1) г, е, ж, з.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота