В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nsotskova
nsotskova
15.05.2020 05:58 •  Информатика

РЕШИТЬ ЭТУ ЗАДАЧУ НА ПАСКАЛЬ Имеется N гор Каждая гора это треугольник, основание которого лежит на оси х. Обе стороны горы наклонены под углом 45 градусов, поэтому пик горы - угол в 90 градусов. Гора i поэтому задаётся координатами (xi yi) ее газ
пика. Никакие две горы не имеют одно и то же расположение пика
Требуется посчитать все видимые горы Но, поскольку все они примерно одного цвета невозможно увидеть гору, если ее пик лежит на границе или внутри другой горы.
Определите количество различных пиков (и следовательно гор), которые можно увидеть.
Формат ввода (файл mountains.im):
Первая строка ввода содержит N. Каждая из оставшихся N строк содержит хi (0<xis1019) и уi (1syjs109) описывающих пики гор.
Формат вывода (файл mountains.out):
Выведите минимальное количество гор, которые можно различить.
Пример ввода
3
46
72
25
Пример вывода
2​​

Показать ответ
Ответ:
bereza11
bereza11
20.06.2022 23:12
#include <iostream>
#include <cmath>
using namespace std;

void main() 
{
int n,sum=0; 
float y,k=0; 
cin >> n; 
int *mass = new int[n]; 
for (int i = 0;i < n;++i) 
{
cin >> mass[i]; 

for (int i = 0;i < n;++i) 

if (mass[i] >0 )
{
k++;
y=pow(mass[i],2); 
cout<<y;
sum+=mas[i]
}

system("pause"); 
}

2)#include <iostream>
#include <cmath>
using namespace std;

void main() 
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
0,0(0 оценок)
Ответ:
kril20101
kril20101
18.09.2021 08:02
//я писал этот унылый код полтора часа. Полтора часа, Карл! Я слишком расслабился.
#include <iostream>
using namespace std;
int k=2;

bool StrangeSeq(int n){
     if (k<n){
              if(n%k==0){
                         cout<<"false";
                         return false;
                         }
                         k++;
                         StrangeSeq(n);
                         }
                         else
                         {
                             cout<<"true";
                             return true;
                             }
}
                
int main(){
    int n;
    cin>>n;
    StrangeSeq(n);
    cin.get();
    cin.get();
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота