В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
siplatoffmatvei
siplatoffmatvei
06.03.2021 05:14 •  Информатика

Решить это на любом языке программирования. Напишите программу, на вход которой с клавиатуры в первой строке подается натуральное число n ‐ количество показаний прибора (n<12000). Начиная со второй строки, подаются сами показания прибора ‐ целые числа из диапазона [10, 21999999] по одному в строке. Программа должна вывести в порядке убывания те из них, которые меньше среднего арифметического всех показаний.

Показать ответ
Ответ:
BigD13
BigD13
15.10.2020 14:57

Написал Вам код на Python-е, держите (также прилагается скриншот с самим кодом и выводом компилятора для наглядного ориентира):

n = int(input('Enter the number of readings of the device: n = '))

readings_list = []

for num_of_readings in range(1,n+1):

       prompt_row = 'Enter ' + str(num_of_readings) + ' reading: '

       reading = int(input(prompt_row))

       readings_list.append(reading)

arithm_mean = 0

for num_of_readings in range(n):

   arithm_mean += readings_list[num_of_readings]

arithm_mean /= n

selected_values_list = []

selected = 0

for num_of_readings in range(n):

   if (readings_list[num_of_readings] < arithm_mean):

       selected = readings_list[num_of_readings]

       selected_values_list.append(selected)

selected_values_list.sort(reverse = True)

if (len(selected_values_list) == 0):

   print('There is no values that are less than the arithmetic mean')

else:

   print('Values that are less than the arithmetic mean - ',*selected_values_list,sep = '  ')


Решить это на любом языке программирования. Напишите программу, на вход которой с клавиатуры в перво
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота