В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
anelya41
anelya41
15.01.2022 15:00 •  Информатика

Решить двумя напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1. пример: введите число? 311 единиц: 2

Показать ответ
Ответ:
Gansterghkl
Gansterghkl
05.10.2020 14:38
Program n1;
var num,k: integer;
begin
write('Введите число ');
readln(num);
k:=0;
while num<>0 do
begin
if abs(num mod 10)=1 then
k:=k+1;
num:=num div 10;
end;
writeln('Единиц: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота