В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nv5n4kp0ds5f
nv5n4kp0ds5f
13.03.2023 10:31 •  Информатика

решить через Python. 1. Сложные условия AND, OR, NOT
Введите три числа. Найдите их произведение.
Если их произведение меньше 20 или больше 30, то выведите сообщение «ДА», иначе выведите сообщение «НЕТ».
2. решить задачу на Python.
1. Найти сумму числового ряда s=1+1/2+1/3+1/4++1/n
Решаем задачу через цикл.
2. Даны 2 числа, они не равны. Найти минимальное. Заменить минимальное половиной суммы этих двух чисел, а большее число удвоенным произведением этих двух чисел.
3. решение задач.
1. найти сумму четных чисел из диапазона от 5 до 20.
2. найти произведение чисел кратных 7 из диапазона от 7 до 49.
3. найти произведение не четных чисел из диапазона от 3 до 10.
4. Нарисуйте на экране «прямоугольник» из двух видов символов.
5. составить программу на Python.
1. напечатать числа кратные 7 из диапазона от 50 до 90.
2. найти произведение чисел не кратных 8 из диапазона от 60 до 90.

Показать ответ
Ответ:
Jeka990
Jeka990
02.01.2022 12:38
По логике так:
Надо расположить по возрастанию, то есть первое меньше второго, второе меньше третьего. Поэтому под цифрами 1 и 2 надо поставить "больше": если цифры поменяются местами, то станет "меньше", что нам и надо. Порядок убывания нам не нужен - нужно возрастание, поэтому в 3 пункте "не расположены". Ну а "к пункту" можно только "вернутся")

1)Начало.
2) Сравни первое и второе числа; если первое больше второго , то поменяй их местами.
3)Сравни второе и третье числа; если второе больше третьего, то поменяй их местами.  
4)Если теперь три числа не расположены в порядке убывания, то исполни пункт 5) этого алгоритма; иначе вернись к пункту  2).
5)Конец.
0,0(0 оценок)
Ответ:
ninacat1
ninacat1
07.12.2020 17:44
#include <iostream>
using namespace std;

int main()
{
    setlocale (LC_ALL,"Russian");
    int number;
    do
    {
        cout <<"Введите номер группы: ";
        cin >> number;
    }
    while (number<100 || number>999);
    char *groups[9]={"исторический","экономический","юридический",
                             "математический","физический","химический",
                             "биологический","географический","географический"};
    cout <<groups[number/100-1] <<", поступил в 200" <<number/10%10
           <<" году\n";
    return 0;
}
Как задание понял, так и написал
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота