В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Катя2731
Катя2731
03.07.2022 08:43 •  Информатика

Решение задачи на языке ассемблер.Написать программу для вычисления степени числа 3 по формуле a=3n. Число а - 16-битное целое без знака, число n- 8-битное число без знака(используйте n меньше 11, чтобы избежать переполнения). Проверьте работу программы в отладчике(нажимайте F7 на команде Loop, чтобы осуществить переход)

Показать ответ
Ответ:
Умка2804
Умка2804
15.05.2021 21:33
Без проверки полагаем, что по заданным координатам точек можно построить треугольники.

//PascalABC.Net 3.0, сборка 1111
type
  Point=record
  x,y:double
  end;

function TriangleSquare(A,B,C:Point):double;
begin
  Result:=0.5*abs(A.x*(B.y-C.y)+B.x*(C.y-A.y)+C.x*(A.y-B.y))
end;

procedure GetPoint(c:char; var A:Point);
begin
  Write('Введите координаты точки ',c,': ');
  Readln(A.x,A.y)
end;

var
  A:array['A'..'F'] of Point;
  i:'A'..'F';
  s1,s2:double;
begin
  for i:='A' to 'F' do GetPoint(i,A[i]);
  s1:=TriangleSquare(A['A'],A['B'],A['C']);
  s2:=TriangleSquare(A['D'],A['E'],A['F']);
  if s1>s2 then Writeln('Площадь первого треугольника больше')
  else
    if s2>s1 then Writeln('Площадь второго треугольника больше')
    else Writeln('Площади треугольников равны')
end.

Тестовое решение:
Введите координаты точки A: -4 3.7
Введите координаты точки B: -6.3 0
Введите координаты точки C: 10.2 5.93
Введите координаты точки D: 7.143 8.1
Введите координаты точки E: -6 -3
Введите координаты точки F: 7.4 -5.7
Площадь второго треугольника больше
0,0(0 оценок)
Ответ:
DXDynamic31
DXDynamic31
03.10.2022 10:05
2. процессор-микропроцессор, который выполняет задачи, алгоритмы, управляя компьютером.
системный блок-большая коробка, корпус, в котором находятся все комплектующие компьютера.
3. это конечная последовательность однозначных предписаний, исполнение которых  позволяет с конечного числа шагов получить решение задачи, однозначно определяемое исходными данными.
4.стационарный или подвижный объект, который представляет собой комплекс технических средств обработки информации, предназначенный для выполнения определенных функций
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота