Решение в паскале написать программу, которая уменшнает на 10 введенное с клавиатуры двузначное число, на 100 - если трехзначное. условие окончания программы - введение нулевого числа. уведомление о некорректности данных вывести красным цветом, а про окончание работы - зеленым.
var
n:integer;
begin
repeat
textcolor(15);
Write('n='); Read(n);
if n=0 then begin
textcolor(LightGreen);
Writeln('Работа завершена');
textcolor(15);
end
else
if (n>9) and (n<100) then begin
n:=n-10;
Writeln('Результат: ',n)
end
else
if (n>99) and (n<1000) then begin
n:=n-100;
Writeln('Результат: ',n)
end
else begin
textcolor(LightRed);
Writeln('Недопустимое значение');
end;
until n=0;
ReadKey { для PascalABC.NET можно удалить эту строку }
end.