В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dvydenko
dvydenko
06.12.2021 20:57 •  Информатика

РЕБЯТА УМОЛЯЮ ЭТО ПРОВЕРОЧНАЯ НУЖНО Напишите программу, которая в последовательности натуральных чисел определяет сумму всех

чисел, кратных 3 и оканчивающихся на 9. Программа получает на вход натуральные числа, количество

введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания

ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не

превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 3 и

оканчивающихся на 9.

Пример работы программы:

Входные данные Выходные данные

16

29

56

9

39

0

48​

Показать ответ
Ответ:
ладдщв
ладдщв
24.12.2020 07:56

7)На координатной плоскости отмечены числа p,q и r.

Какая из разностей q-p, q-r, r-p отрицательная.

ответ: q-r такая из разниц будет отрицательная

8)

9)

х=±7

ответ :-7

10) Костя не выучил 4 билета всего 25 билетов

25-4=21

Вероятность что Кости попадется билет который он знает 21/25=0,84

13) 8х-3(х+9)≥-9

8х-3х-27≥-9

8х-3х≥-9+27

5х≥18

х≥18/15

х≥3,6

ответ: [3,6;∞) №1

14) 1 минута образуется осадок 0,2 грамма

а1=0,2 гр

а7= неизвестная переменная

d = 0,5 - на столько каждую минуту увеличивается масса осадка.

Формула n-ого члена арифметической прогрессии выглядит так:

аn = a1 + d(n - 1).

Подставляем данные величины:

а7 = 0,2 + 0,2(7 - 1) = 0,2 + 1,2= 1,4грамма

ответ: 1,4 грамма

Объяснение:

0,0(0 оценок)
Ответ:
domaris246
domaris246
17.04.2021 17:14

Итак, целевой язык - C++. Это значит мы - радостные обладатели технологии потоков, с коей мы будем производить весь ввод/вывод как при работе с файлами, так и при работе со стандартным вводом/выводом (консолью).

Ну а раз уж мы работаем с потоками, то будем делать это красивенько: создадим класс-обёртку для потока ввода, цель которого - поиск в этом потоке цитат и отправка их на поток вывода (который мы передаём).

[!] Стоит отметить, что по заданию не сказано, что есть разница между ' и ". Поэтому будем считать их одинаковыми.

[!] Внимание! Рядом с исполняемым файлом надо создать текстовый файл data.txt c текстом и цитатами.

Код

С++11

#include <iostream>#include <fstream>using std::cout;class QuotesFinder {    std::istream &in_stream;    bool is_it_in_quote = false;public:    QuotesFinder() = delete;    QuotesFinder(QuotesFinder&&) = default;    QuotesFinder(QuotesFinder const&) = default;    explicit QuotesFinder(std::istream &is) : in_stream(is) {}    [[nodiscard]]    bool eof() const {        return in_stream.eof();    }    // Вот тут происходит вся магия    QuotesFinder& operator >> (std::ostream& out_stream) {        char buffer;        in_stream.get(buffer); //Получаем очередной символ из потока        if (buffer == '\"' || buffer == '\'') {            if (is_it_in_quote) {                is_it_in_quote = false;                out_stream << buffer;                out_stream << "\n";                return *this;            }            is_it_in_quote = true;        }        if (is_it_in_quote) {            out_stream << buffer;        }        return *this;    }};int main() {    std::ifstream file("data.txt");  // Открываем файл    if (!file.is_open()) {        cout << "File is not exits!";        return 1;    }    QuotesFinder finder(file);  // Создаём обёртку из файлового потока    while (!finder.eof()) // Пока не достигли конца потока        finder >> cout; // переправляем очередной кусок информации в поток вывода}
Написать программу на С++. Задача - Считать текст из файла и вывести на экран только цитаты, т. е. п
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота