В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
likaoolika
likaoolika
10.08.2020 00:41 •  Информатика

Реализация разветвляющегося алгоритма с++

20. составить программу для вычисления значения выражения: max (a, bc, min(d, b))

нужен код программы выручайте)

Показать ответ
Ответ:
холера663
холера663
05.02.2020 12:51
1.
0,5 Кбайт = 0,5*1024 байт = 512*8 бит
512*8/128 = 32

2.
Память для одного символа = log(2)64=6 бит
Объем текста = 10*32*64*6 бит = 10*32*64*6/8 байт =
10*4*64*6/1024 Кбайт = 15 Кбайт

3.
3 Кбайт = 3*1024 байт = 3*1024*8 бит
Память для одного символа = 3*1024*8/6144 = 4 бита
Количество символов в алфавите = 2^4 = 16

4.
Память для одного символа = log(2)128=7 бит
Объем сообщения = 10*7 = 70 бит

8.
a) 3 Кбайт=3*1024 Байт = 3072 бАЙТ
b) 2 Мбайт=2*1024 Кбайт = 2*1024*1024 байт = 2*1024*1024*8 бит = 16777216 бит
c) 4,5 Гигабайт=4,5*1024 Мбайт = 4,5*1024*1024 Кбайт = 4718592 Кбайт
0,0(0 оценок)
Ответ:
катя4143
катя4143
09.03.2020 09:20

program nomerstolb;

Var a: array[1..50,1..50] of integer;


 

b: array[1..50] of integer;

i, j, m, n, max, jmax: integer;

Begin

Write(‘сколько строк?’); Readln(m);

Write(‘сколько столбцов?’); Readln(n);

For i:=1 to m do

begin

For j:=1 to n do

begin

write(‘a[‘,i,’,’,j,’]=’); readln (a[i,j]);

end;

for j:=1 to m do

begin

b[j]:=0;

for i:=1 to n do

if a[i,j]<0 then b[j]:=b[j]+1;

end;

max:=b[1]; jmax:=1;

For j:=2 to n do

begin

if b[j]>max then

begin

max:=b[j]; jmax:=j;

end;

end;

writeln(‘Наибольшее количество отрицательных элементов в ‘;jmax ; ‘столбце’);

end;

end.

9. Упорядочить каждый столбец матрицы по возрастанию. Массив размером МхN, элементы которого задаются датчиком случайных чисел на интервале [-17;26].

 

program porydok;

Var a: array[1..50,1..50] of integer;

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота