В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Kate7779393727
Kate7779393727
26.12.2020 20:28 •  Информатика

разработать библиотечный модуль, содержащий следующие подпрограммы (процедуры или функции) для работы со строками:
а. удалить пробелы в начале строки и в конце строки
б. удалить лишние пробелы (между словами оставить по одному пробелу)
в. удвоить все пробелы в строке
написать программу, к которой подключается модуль, демонстрирующую работо всех подпрограмм модуля.

Показать ответ
Ответ:
Хафиза1
Хафиза1
16.04.2023 05:23
{
правильная программа, кол-во элементов вводится с клавиатуры
}
Program Summa;
uses crt;
type a1= array of integer;
var a: a1;
m,s,n: integer;
procedure Input;
const p=1;
const q=20;
var i: integer;
begin
randomize;
begin
for i:=0 to n-1 do a[i]:=random(q-p+1)+p;
write('a[',i,']=');
readln(a[i]);
end;
end;
procedure Print;
var i: integer;
begin
write('Массив целых чисел А: ');
for i:=0 to n-1 do write(' ',a[i]);
writeln;
writeln;
end;
procedure Sum( m: integer);
var i: integer;
begin
s:=0;
for i:=0 to m-1 do s:=s+a[i];
end;
Begin
ClrScr;
write('введите кол-во элементов в массиве: ');
readln(n);
SetLength(a, n);
Input;
ClrScr;
Print;
write('Сколько элементов суммировать: ');
readln(m);
Sum(m);
writeln;
writeln('Сумма ',m,' элементов масссива равна: ', s);
Sum(n);
writeln;
writeln('Сумма всех ',n,' элементов массива равна: ', s);
Writeln ('Среднее арифмитическое всех элементов равно ', s/n);
Readkey;
end.
0,0(0 оценок)
Ответ:
Volovoy00T
Volovoy00T
11.12.2022 20:06
Общий вес груза = 7*10+7*5 = 105 т, следовательно, на каждой палубе должно быть по 105/3 = 35 т.
35 т. можно получить следующими
10 т  5 т
3       1
2       3
5       1
0       7
Комбинируя эти варианты, получим следующие варианты распределения контейнеров:
1:
10 т   5 т   0 т
3       1      3   (всего 7, вес 35 т)
3       1      3   (всего 7, вес 35 т)
1       5      1   (всего 7, вес 35 т)

7       7      7

2:
10 т   5 т   0 т
3       1      3   (всего 7, вес 35 т)
2       3      2   (всего 7, вес 35 т)
2       3      2   (всего 7, вес 35 т)

7       7      7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота