В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Nastya28612
Nastya28612
25.06.2022 16:33 •  Информатика

Разработать алгоритм и составить программу на выбранном языке программирования ( паскаль или qbasic) для нахождения произведения цифр числа, полученного при умножении числа 12 на свой порядковый номер в списке группы.

Показать ответ
Ответ:
Merto
Merto
09.07.2020 19:20
Var
  m, n, p: integer;

begin
  Write('Введите свой номер в группе: ');
  Readln(n);
  n := n * 12;
  p := 1;
  repeat
    m := n mod 10;
    p := p * m;
    n := n div 10
  until n = 0;
  Writeln('Результат ', p)
end.

Тестовое решение:

Введите свой номер в группе: 13
Результат 30
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота