В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
eelina05
eelina05
12.10.2022 21:41 •  Информатика

Разделить массив, заполненный случайным образом только положительными числами, на два - четных и нечетных. составить блок схему и написать программу.

Показать ответ
Ответ:
aleksandrakival2989
aleksandrakival2989
30.06.2020 09:54
Uses crt;
const n=10;
var a,b,c: array [1..n] of integer;
    x,y,z,k: integer;
begin
     y:=0;
     z:=0;
     for x:=1 to n do begin
         a[x]:=random(100)+1;
         if a[x] mod 2=0 then begin
            inc(y);
            b[y]:=a[x];
            end
            else begin
                 inc(z);
                 c[z]:=a[x];
            end;
         write(a[x]:4);
     end;
     writeln;
     k:=y;
     for y:=1 to k do
         write(b[y]:4);
     writeln;
     k:=z;
     for z:=1 to k do
         write(c[z]:4);
end.
Разделить массив, заполненный случайным образом только положительными числами, на два - четных и неч
0,0(0 оценок)
Ответ:
MstyanKristina
MstyanKristina
30.06.2020 09:54
Program test;
var i,k,z:integer;
m:array[1..100] of integer;
c:array[1..100] of integer;
n:array[1..100] of integer;
begin
randomize;
for i:=1 to 10 do
begin
m[i]:=random(1000); 
if m[i] mod 2 =0  then 
begin 
k:=k+1; 
c[k]:=m[i]; 
end 
else 
begin  z:=z+1; 
n[z]:=m[i]; 
end;
end;
for i:=1 to z do
write('     НЕЧЕТНЫЕ',n[i]);
writeln();
writeln();
for i:=1 to k do
write('      ЧЕТНЫЕ',c[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота