В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Бос2017
Бос2017
27.10.2020 07:31 •  Информатика

Работа с системой программирования на языке Паскаль
1) Напишите программу для реализации следующего сценария:
• целочисленный массив заполняется случайными числами (размерность
массива и числовой диапазон определите самостоятельно);
• выводится сообщение «Заполненный массив»;
• с новой строки выводятся элементы массива в строку через пробел;
• выводится сообщение «Введите значение числа К»;
• запрашивается ввод с клавиатуры целочисленного значения числа К;
• выводится сообщение «Элементы массива, кратные К»;
• осуществляется поиск в массиве элементов, кратных числу К;
• выводятся элементы массива, кратные числу К.

Показать ответ
Ответ:
Изачка
Изачка
23.03.2022 09:10
#include <iostream>
#include <vector>
using namespace std;

int main() {
cout << "Введите массив (0, чтобы закончить):\n";
int k,
sb = 0, cb = 0,
sg = 0, cg = 0;
vector<int> v;
while (true) {
cin >> k;
if (k == 0)
break;
else
v.insert(v.end(), k);
}
for (int i = 0; i < v.size(); i++) {
if (v[i] < 0) {
sb += -1 * v[i];
cb++;
}
else {
sg += v[i];
cg++;
}
}
cout << "Средний рост юношей: "
<< (sb / cb) << '\n'
<< "Средний рост девушек: "
<< (sg / cg) << '\n';
return 0;
}
0,0(0 оценок)
Ответ:
Jujuliliaa
Jujuliliaa
02.05.2020 22:49
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

procedure MyArray(n:integer;var a:array of integer);
begin
  a:=ArrFill(n,0); // заполняем массив нулями
  Randomize; // инициализируем датчик случайных чисел
  // в случайный элемент заносим слчайное значение
  a[Random(0,n-1)]:=Random(1,99)
end;

begin
  var n:=ReadInteger('n='); // читаем с клавиатуры размер массива
  var mas:array of integer;
  MyArray(n,mas); // вызываем процедуру
  mas.Println // выводим сформированный массив
end.

Пример
n= 21
0 0 0 0 0 0 0 56 0 0 0 0 0 0 0 0 0 0 0 0 0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота