В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
мопс173
мопс173
24.09.2021 12:07 •  Информатика

Python В игре "Хлопок" все участники стоят в кругу. Ведущий определяет кто начинает игру и объявляет целое число. Дальше участники по часовой стрелке называют последующее число, но если это число делится на 3, то они просто производят хлопок.

Напишите программу, которая на входе принимает два натуральных числа: a - начальное значение игры,  n - конечное значение. Для каждого из чисел в последовательности вывести слово "Хлопок", если число делится на 3, иначе вывести само число.

Входные данные:

Два целых числа a и n (a < n)

Выводные данные:

Результат вывода в столбик​

Показать ответ
Ответ:
T1shka136
T1shka136
15.10.2020 15:43

a, n = map(int, input().split())

for i in range(a + 1, n + 1):

   if i % 3 == 0:

       print("Хлопок")

   else:

       print (i)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота