В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
калина007
калина007
14.03.2021 14:11 •  Информатика

Python Треугольник Паскаля Даны два числа n и m. Создайте массив × и заполните его по следующим правилам: Числа, стоящие в строке 0 или в столбце равны 1 (A[0][j] = 1, A[i][0] = 1). Для всех остальных элементов массива A[i][j] = A[i-1][j] + A[i][j-1], то есть каждый элемент равен сумме двух элементов, стоящих слева и сверху от него. Входные данные Вводятся два натуральных числа n и m , не превышающих 100. Выходные данные Выведите данный массив на экран. Примеры Ввод 3 3 Вывод 1 1 1 1 2 3 1 3 6

Показать ответ
Ответ:
Татьяна64101
Татьяна64101
15.10.2020 15:44

n, m = map(int, input().split())

A = [[0]*m for i in range(n)]

for i in range(m):

   A[0][i] = 1

for i in range(n):

   A[i][0] = 1

for i in range(1, n):

   for j in range(1, m):

       A[i][j] = A[i-1][j] + A[i][j-1]

for i in range(n):

   print(*A[i])

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота