Python Руны — это древние магические знаки, которые наши предки использовали как буквы. Говорят, что рунные знаки обладают магическими свойствами, а при сложении рун в слова их магическая сила многократно возрастает. Если кузнец изготовит доспехи и начертит там определенные руны в определенном порядке, то доспехи будут наделены необычайными магическими силами.
Для того, чтобы стать обладателем таких доспехов достаточно просто принести кузнецу начертания этих рунных знаков. А вот, чтобы стать обладателем рунного знака приходилось немало потрудиться. Воины добывали начертания рун других языков и наречий в боях или получали их в качестве наград в благодарность за оказанные услуги.
Но так или иначе и в этом деле развелись жулики. По подозрениям ученых кузнец Игнатус Мошеникус изготавливал благородным воинам фальшивые рунные слова. Из древних преданий ученым стало достоверно известно, что каждая руна записывается из двух, трех или четырех английских букв. Причем первая буква рунного слова всегда записывается как заглавная, а все остальные являются маленькими. Ученые перевели несколько, выкованных этим кузнецом, рунных слов на английский язык и теперь нуждаются в Вашей . Проверьте, является ли приведенное слово рунным.
Входные данные
В единственной строке содержится слово. Оно представляет собой непустую строку, длиной не более 100000 символов, содержащую только большие и маленькие буквы английского алфавита.
Выходные данные
Выведите «Yes», если слово является рунным и «No» в противном случае.
Пример
№ INPUT.TXT OUTPUT.TXT
1 IoIsTheBest Yes
2 IoItIsWaste No
Представлю 3 программы два с массивом и один без массива
1)var a:array [1..10] of integer;
i,n,k5,k2:integer;
begin
writeln('введите количество экзаменов');
read(n);
for i:=1 to n do begin
writeln('введите оценку за экзамен');
readln(a[i]);
end;
for i:=1 to n do begin
if a[i]=5 then k5:=k5+1;
if a[i]=2 then k2:=k2+1;
end;
writeln('количество пятерок ',k5);
writeln('количество двоек ',k2);
end.
2)var a:array [1..10] of integer;
i,n,k5,k2:integer;
begin
writeln('введите количество экзаменов');
read(n);
for i:=1 to n do begin
writeln('введите оценку за экзамен');
readln(a[i]);
if a[i]=5 then k5:=k5+1;
if a[i]=2 then k2:=k2+1;
end;
writeln('количество пятерок ',k5);
writeln('количество двоек ',k2);
end.
3)var a,i,n,k5,k2:integer;
begin
writeln('введите количество экзаменов');
read(n);
if n<=10 then begin
for i:=1 to n do begin
writeln('введите оценку за экзамен');
readln(a);
if a=5 then k5:=k5+1;
if a=2 then k2:=k2+1;
end;
writeln('количество пятерок ',k5);
writeln('количество двоек ',k2);
end;
end.
1.
program z1;
var k: integer;
begin
write ('Введите число: ');
readln(k);
if k > 0 then k:=k*2
else k:=sqr(k);
write('Сейчас число: ',k)
end.
2.
program z2;
uses GraphABC;
var k: integer;
begin
SetFontSize(15);
write ('Введите число: ');
read(k);
write(k);
if k mod 2 = 0 then
begin
SetBrushColor(clred);
FillRectangle(220,140,420,340)
end
else
begin
SetBrushColor(clblue);
FillCircle(320,240,100)
end
end.
3.
program z3;
var k: integer;
begin
write ('Введите число: ');
readln(k);
write((k>99)and(k<1000))
end.
Объяснение:
Условный оператор:
if условие then действие 1 else действие 2
k > 0 - условие проверки числа на положительность (если число больше 0)
k mod 2 = 0 - условие проверки числа на чётность (если число делится на 2 без остатка)
mod - остаток от целочисленного деления
write((k>99)and(k<1000)) - если число трёхзначное, то ответ True, иначе False