В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
89280704228
89280704228
17.05.2021 13:05 •  Информатика

PYTHON: Решение уравнения с использованием функции перебора
Напишите программу, которая находит все решения уравнения x^3-3x^2-9x-20=-8sinx+8cosx на интервале [-5;5]. Программа должна выполнить следующие действия:

1. Определяет и выводит на экран интервалы, на которых расположены корни уравнения.

2. На каждом интервале, используя метод перебора, ищет решение с точностью 0,001 и выводит полученные решения на экран.

Вычисление функции, стоящей в левой части уравнения, оформите в виде подпрограммы.

Показать ответ
Ответ:
Melenocka0606
Melenocka0606
13.03.2021 19:53

Для завантаження фільмів на сайт YouTube потрібно створити власний канал, який у подальшому буде містити добірку відеофайлів користувача. Користувач може керувати доступом до перегляду кожного з відеофайлів, установлюючи певний рівень конфіденційності.

Значна частина редакторів відео мають засоби для розміщення відеофільмів в Інтернеті, наприклад така програма, як WindowsMovieMaker.

Мультимедійні файли, призначені для розміщення в Інтернеті, називають подкастами, а тих, хто створює такі файли, подкастерами.

0,0(0 оценок)
Ответ:
Rake4
Rake4
14.03.2023 03:22
//Dev-C++ 5.11 (C)

#include <stdio.h>

int main(void)
 {FILE* f;
 int counter=0,pre,next,b=1;
 f=fopen("input.txt","r");
 fscanf(f,"%d",&pre);
 if (feof(f))
  b=0;
 else
  fscanf(f,"%d",&next);
 while (!(feof(f)) && b)
  {if(pre<next)
   counter++;
  pre=next;
  fscanf(f,"%d",&next);}
 if(pre<next)
   counter++;
 fclose(f);
 f=fopen("input.txt","a");
 fprintf(f,"\n%d",counter);
 fclose(f);
 return 0;}

Пример содержимого input.txt до работы программы:
12
123124124
2132134
12412
123123312
12
12345
Пример содержимого input.txt после работы программы:
12
123124124
2132134
12412
123123312
12
12345
3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота