В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
rim2891
rim2891
03.11.2021 10:42 •  Информатика

Python. Пользователь программы вводит натуральное число N. Напишите программу, выводящую на экран первые N натуральных чисел, кратных 3 (по три числа в строке через пробел)

Показать ответ
Ответ:
6edn9ga
6edn9ga
22.09.2020 08:32

информатика-это наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений

информа́ция — сведения независимо от формы их представления.

свойства информации

1)ценность

максимально возможная польза для достижения цели

2)актуальность

соответствие текущему моменту времени

3)достоверность

истинность представлений об источнике информации

4)доступность (понятность)

способность потребителя к восприятию информации

5)объективность

отображение внешнего мира независимо от наблюдателя

6)полнота

степень подробностей представлений об объекте

процессы информации

1)передача информации

процесс перемещения данных от одного пункта (источника) к другому (приемника)

2)хранение информации

действия с целью защиты найденной информации от потери, повреждения, разрушения

3)обработка информации

совокупность целенаправленных действий с полученной информацией для получения новой информации

этапы эвм

первое поколение

элементная база эвм первого поколения (конец 40-х — середина 50-х) — электронные схемы, построенные с использованием радиоламп. пример эвм первого поколения — бэсм-1(1950г.) — содержала около 7000 радиоламп, выполняла около 8000 арифметических и логических операций в секунду. , решаемые этой машиной: эксперименты по переводу научно-технических текстов с на язык, шахматные . бэсм-1 занимала большой зал, где требовалась вентиляция, стабильные источники питания, смена ламп. примеры других эвм первого поколения: цвм стрела, минск-1, м-20 и др.

  второе поколение

основа элементной базы эвм второго поколения (сер. 50-х — 70-х гг.) — элементы (, диоды). приборы позволили резко увеличить скорость выполнения операций, и быстродействие достигло нескольких миллионов операций в секунду. в эвм второго поколения использовались зу с объемом памяти на сотни тысяч машинных слов. эвм второго поколения: бэсм-2, бэсм-3, бэсм-3м, машины серии урал, мир, наири и др.

третье поколение

третье поколение эвм связывают с использованием интегральных схем (ис) среднего уровня интеграции. на одном кристалле реализуются достаточно сложные логические функции, и из них собираются сложные узлы машин. примеры эвм третьего поколения: ibm — 360, урал-12, урал-13, урал-14. самые большие семейства машин третьего поколения — это ес эвм (единой серии). быстродействие этих машин: сотни тысяч операций в секунду, объем памяти — сотни тысяч машинных слов.

0,0(0 оценок)
Ответ:
ppetrovaa
ppetrovaa
29.01.2023 12:17
Как ч понял сортировка по неубыванию это сортировка по возрастанию. То есть легкие элементы всплывают наверх, а тяжелые перемещаются вниз:

//Pascal
const m = 1000
var
    arr: array[1..m] of integer;
    n,i, j, k: integer;
begin
    readln(n);
    write ('Исходный массив: ');
    for i := 1 to n do begin
        readln(arr[i]);
    end;
//сортировка методом пузырька   
    for i := 1 to n-1 do
        for j := 1 to n-i do
            if arr[j] > arr[j+1] then begin
                k := arr[j];
                arr[j] := arr[j+1];
                arr[j+1] := k
            end;
 
    write ('Отсортированный массив: ');
    for i := 1 to n do
        write (arr[i]:4);
end.

Алгоритм сортировки на классическом языке программирования С

# define SWAP(A,B) {A=A^B;B=A^B;A=A^B;}
void bubblesort(int A[], int n)
 {
     int i, j;
     for(i = n-1 ; i > 0 ; i--)
          { for(j = 0 ; j < i ; j++)
               {
                   if( A[j] > A[j+1] ) SWAP(A[j],A[j+1]);
               }
           }
   }
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота