В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Scucorif
Scucorif
11.02.2023 20:16 •  Информатика

Python. Напишите программу, которая выводит на экран столбец матрицы, сумма элементов которой наименьшая

Показать ответ
Ответ:
dimar3256
dimar3256
02.05.2021 05:58

from random import randint

n, m = 5, 5

A = [[randint(1, 10) for j in range(m)] for i in range(n)]

for row in A:

 for x in row:

   print("{:4d}".format(x), end='')

 print()

b = [sum(x) for x in zip(*A)]

 

print('Суммы по столбцам')

print(b)

k = b.index(min(b))

print('Индекс столбца с наименьшей суммой : ', k)

print('----------------')

for i in range(m) :

 print(A[i][k])


Python. Напишите программу, которая выводит на экран столбец матрицы, сумма элементов которой наимен
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота