В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
radchenkoalink
radchenkoalink
11.05.2021 08:21 •  Информатика

Python: напишите программу, которая ищет количество нетривиальных делителей заданного натурального числа.

Показать ответ
Ответ:
Полькаа1642
Полькаа1642
04.03.2021 19:37

number = int(input('Введите число: '))

divisors = []

for divisor in range(2, number):

   if number % divisor == 0:

       divisors.append(divisor)

print('Кол-во нетривиальных делителей: ', len(divisors))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота