Python. Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить количество автомобилей, скорость которых не превышала 30 км/ч.
Программа получает на вход число проехавших автомобилей N (1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести количество автомобилей, скорость которых не превышала 30 км/ч.
Var a, b, c:integer;
Begin
Readln(a,b,c);
If a>=b+c then Writeln('Нет' )
Else if b>=a+c then Writeln('Нет')
Else if c>=a+b then Writeln('Нет')
Else Writeln('Да');
End.
Использование русских букв в названии переменной (с) это очень сильно, а ещё кавычки не `, а ' должны быть. Код можно еще улучшить избавившись от большого кол-ва проверок if т. к. это замедляет компиляцию
Var a, b, c:integer;
Begin
Readln(a,b,c);
If (a>=b+c) or (b>=a+c) or (c>= a+b) then Writeln('Нет' )
Else Writeln('Да');
End.
если вам надо перевести его в какую-нибудь систему счисления, то нужно делить это число на номер системы, так если нужно перевести число 137 в ДВОичную ,то делим на 2 до тех пор, пока остатотк от деления не равен 1.(если в ТРОичную то на 3 и т.д.).
начнём:
137 / 2 = 68 выписываем остаток (1)
68 / 2 = 34 выписываем остаток (0)
34 / 2 = 17 выписываем остаток (0)
17 / 2 = 8 выписываем остаток (1)
8 / 2 = 4 выписываем остаток (0)
4 / 2 = 2 выписываем остаток (0)
2 / 2 = 1 <== на этой единице заканчиваем деление, далее снизу вверх выписываем получившееся число : 001001;
ответ: 001001