В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
marha18
marha18
21.04.2023 20:49 •  Информатика

(Python) написать программу, которая считывает числа, вводимые пользователем, пока пользователь не введёт слово “end”. Предполагайте, что пользователь вводит только целые числа или слово “end”. В конце программа должна вывести все введённые числа через запятую и их сумму и среднее значение.
Пример вывода
Enter numbers:
1
10
25
-1
0
3
67
end
You entered: 1, 10, 25, -1, 0, 3, 67
Total: 105
Average: 15.0
Указания:
Используйте цикл while для ввода чисел и сохраняйте их в списке.
Используйте цикл for для подсчёта суммы чисел в полученном списке.

Показать ответ
Ответ:
chestnut3342
chestnut3342
12.10.2020 10:08

lst = []

count = 0

sm = 0

while True:

   try:

       lst += [int(input())]

   except:

       break

print('You entered:', end=' ')

for i in lst:

   sm += i

   count += 1

   if i != lst[-1]:

       print(i, end=', ')

   else:

       print(i)

print(f'Total: {sm}')

print(f'Average: {sm / count}')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота