В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
diaweeti551
diaweeti551
30.05.2021 17:50 •  Информатика

Python Написать программу, которая определяет среднюю цифру введенного числа. В случае, если средних цифр две вывести бОльшую.

Пример: число: 12345 ответ: 3
число: 543210 ответ: 3

Показать ответ
Ответ:
gogoged
gogoged
23.08.2021 22:50
Когда мы копируем рисунок в буфер, то он определенного размера.
Создадим второго слона. Для этого надо выполнить все 4 команды:
1,2,3,4.
Второй слон стал на 80% меньше первого.
Создадим третьего слона.
Если мы сейчас снова вставим слона из буфера (команда 3), то вставится первый слон, и команду 4 придется делать 2 раза, чтобы он стал на 80% меньше, чем второй слон.
Поэтому для третьего слона нужно выделить второго и опять проделать все 4 команды: 1,2,3,4.
Чтобы получить еще 6 слонов, нужно эти команды повторить 6 раз.
ответ: В) повторить (1,2,3,4; 6)
0,0(0 оценок)
Ответ:
67679
67679
12.09.2021 04:57
//1. Переборный алгоритм Евклида (цикл repeat)

var a, b, с: integer; 

begin

  write('Введите два числа: ');

  readln(a, b);

  if a < b then с := a + 1 else с := b + 1;

repeat с := с - 1

  until (a mod с = 0) and (b mod с = 0);

  write('NOD = ', с)

end.

 

//2. Алгоритм с вычитанием (цикл while)

var  a, b: integer;

begin

  write('a = ');

  readln(a);

  write('b = ');

  readln(b);

  while a <> b do

    if a > b then

      a := a - b

    else

      b := b - a;

  writeln('NOD = ', a);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота