Python На вход подаются строки aa и bb.
Напишите программу, которая определяет, является ли строка aa подпоследовательностью строки bb.
Формат входных данных
На вход программе подаются две строки aa и bb, каждая на отдельной строке.
Формат выходных данных
Программа должна вывести YES, если строка aa является подпоследовательностью строки bb и NO в противном случае.
Примечание. Подпоследовательность строки – это строка , которая формируется из исходной строки путем удаления некоторых (хотя бы одного) символов, не нарушая относительного расположения остальных символов. Например, строка ace является подпоследовательностью строки abcde , а строка aec нет.
Sample Input 1:
ось
восемь
Sample Output 1:
YES
Sample Input 2:
речь
изречение
Sample Output 2:
NO
Sample Input 3:
abcde
abcde
Sample Output 3:
NO
#include <stdio.h>
using namespace std;
int main(){
int y;
cin>>y;
y=y%12;
switch (y){
case 4:{cout<<"Mouse"; break;}
case 5:{cout<<"Bull";break;}
case 6:{cout<<"Tiger";break;}
case 7:{cout<<"Rabbit";break;}
case 8:{cout<<"Dragon";break;}
case 9:{cout<<"Snake";break;}
case 10:{cout<<"Horse";break;}
case 11:{cout<<"Goat";break;}
case 0:{cout<<"Monkey";break;}
case 1:{cout<<"Cock";break;}
case 2:{cout<<"Dog";break;}
case 3:{cout<<"Pig";break;}
}
cin.get();
cin.get();
return 0;
}
#include <iostream>
using namespace std;
int k=2;
bool StrangeSeq(int n){
if (k<n){
if(n%k==0){
cout<<"false";
return false;
}
k++;
StrangeSeq(n);
}
else
{
cout<<"true";
return true;
}
}
int main(){
int n;
cin>>n;
StrangeSeq(n);
cin.get();
cin.get();
}