В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
RTAKZM
RTAKZM
07.07.2020 01:24 •  Информатика

Python Количество локальных максимумов
Элемент последовательности называется строгим локальным максимумом, если он строго больше предыдущего и последующего элементов последовательности. Первый и последний элемент последовательности не являются локальными максимумами.

Входные данные

Дана последовательность натуральных чисел, завершающаяся числом 0. Последовательность содержит не менее трёх элементов. Гарантируется, что все числа не превосходят 100.

Выходные данные

Определите количество строгих локальных максимумов в этой последовательности.

Примеры
Ввод
5 1
0 2
0

Вывод
0 0

Показать ответ
Ответ:
СерёгаД
СерёгаД
10.07.2022 09:17
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger('Вводите:',ReadInteger('n='));
  Writeln(' , меньших 30: ',a.Where(t->t<30).Count);
  Writeln(' , равных 100: ',a.Where(t->t=100).Count);
  Write('Три различных лучших результата: ');
  a.Distinct.OrderByDescending(t->t).Take(3).Println
end.

Пример
n= 23
Вводите: 92 51 93 33 7 60 47 71 24 17 49 35 7 31 6 74 51 86 51 86 100 48 54
, меньших 30: 5
, равных 100: 1
Три различных лучших результата: 100 93 92
0,0(0 оценок)
Ответ:
Хшж
Хшж
03.03.2022 01:03
Уровни наложения заставляют работать не напрямую с машиной, ограничивая язык, а с языком программирования, который содержит другой, более удобный язык, похожий на простой обычный, смысловой, логический, который сам объяснит за вас это машине, так как машина говорит лиш на одном.

вот в чём разница. Низкого уровня язык - это язык машины, но он прямой, как разговор с человеком, а не с переводчиком.

переводчик ведь тоже поправит предложения или полностью заменит их если это выражения языка.

поэтому в языках программирования доступно много всего, всё что захочет создатель
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота