В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Python. Циклы for и while. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). 30 б.

Показать ответ
Ответ:
3754456988561
3754456988561
17.03.2021 22:13

x, s, counter = -1, 0, 0

while x != 0:

   x = int(input())

   if (x>=100) and (x<=999):

       s += x

       counter += 1

if counter == 0:

   print("NO")

else:

   print(s/counter)

0,0(0 оценок)
Ответ:
GarveL
GarveL
17.03.2021 22:13

numbers = []

while True:

   num = int(input('Введите число: '))

   if num == 0:

       break

   if len(str(num)) == 3:

       numbers.append(num)

if numbers != []:

   s = 0

   for num in numbers:

       s += num

   print('Среднее арифметическое:', s / len(numbers))

else:

   print('NO')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота