В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nikzaytsev2001
nikzaytsev2001
24.12.2021 23:49 •  Информатика

PYTHON C++

Ровно К обменов Даны два числа n и k. Вывести перестановку из n чисел (n чисел от 1 до n без повторений) такую, чтобы сортировка пузырьком по возрастанию на соответствующем массиве сделала ровно k обменов. Если возможных ответов несколько — выведите любой. Входные данные Даны натуральное число n (n≤ 100) и целое неотрицательное k. Гарантируется, что для всех наборов тестовых данных решение существует. Выходные данные Выведите искомую перестановку в одной строке. Числа разделяйте пробелами.

Показать ответ
Ответ:
Aituar2007
Aituar2007
15.10.2021 03:22

Кибернетика

Объяснение:

В середине века выдающийся американский учёный Норберт Винер (1894−1964) , изучавший различные технические и биологические системы, установил, что управление в них осуществляется по общей схеме. Винер считается основоположником науки об управлении — кибернетики.

Существует большое количество различных определений понятия «кибернетика», однако все они сводятся к тому, что кибернетика — это наука, изучающая общие закономерности строения сложных систем управления и протекания в них процессов управления. Так как любые процессы управления связаны с принятием решений на основе получаемой информации, то кибернетику часто определяют ещё и как науку об общих законах получения, хранения, передачи и преобразования информации в сложных управляющих системах.

0,0(0 оценок)
Ответ:
Dangerrr
Dangerrr
25.06.2021 09:41

Функция strlen() возвращает длину строки, то есть strlen(str) - длина строки str. В массиве выделено место для 101 символа, так как по условию максимальная длина введенной строки - 100 символов, но еще одно место в массиве нужно для нуль-терминатора(\0), иначе программа не сможет успешно работать со строкой и для некоторых входных данных будет выдаваться ошибка. Так как str - массив символов типа char, то можно обращаться к каждому элементу массива с индекса, что и происходит в цикле for.

Объяснение:

#include <iostream>

using namespace std;

int main()

{

char str[101];

cin >> str;

for (int i = 0; i < strlen(str); i++) {

 cout << str[i];

 if (i != strlen(str)-1) cout << '*';

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота