PYTHON 3 У Арлана есть N шариков красного и синего цвета. Каждый шарик имеет свой вес Mi. Для удобства вес красных шариков будем обозначать положительным числом, а вес синих шариков – отрицательным. Вес шарика не может быть нулевым. Арлан хочет украсить новогоднюю ёлочку парами шариков синего и красного цвета одного веса ему определить, сколько пар можно составить из имеющихся шариков.
Входные данные
В первой строке дано натуральное число N, не превосходящее 100000.
Во второй строке даны N целых чисел Mi. Все числа по модулю не превышают 100.
Выходные данные
Выведите одно число – количество возможных пар.
C++
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "RUS");
// первая задача
int c;
cout << "Введите число c: ";
cin >> c;
if (c % 2 == 0)
{
cout << "YES" << endl;
}
else
{
cout << "NO"<< endl;
}
//вторая задача
int a, b;
cout << "Введите число а: ";
cin >> a;
cout << "Введите число b: ";
cin >> b;
if (a > b)
{
a = a * 2;
cout << a << endl;
}
else
{
b = b * 2;
cout << b << endl;
}
//третья задача
int d;
cout << "Введите число а: ";
cin >> d;
if (d % 2 == 0)
{
d = d / 2;
cout << d << endl;
}
else
{
cout << 0 << endl;
}
return 0;
}
2.извини незнаю
3. Для того, чтобы робот двигался постоянно вдоль черной линии в программе используется бесконечный цикл в нем происходит считывание данных с датчиков цвета, освещенности, анализ данных датчиков и соответсвующие маневры робота. В нашем роботе левый датчик цвета подключен к порту 3, правый датчик подсоединен к порту 1. Левый мотор подключен к порту В, правый мотор к порту А.
4. Датчик цвета позволяет определять цвет поверхности.
5. Поворот с использованием колеса является не очень точным. Если вы попытаетесь повернуть своего робота на пыльной или скользкой поверхности, он может не достичь правильного угла
6.извини незнаю
7. робот видит цвет линии и ездит по ней