В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Downhill28
Downhill28
20.06.2022 09:17 •  Информатика

Python 3 нужно написать программу которая будет вычислять факториал 100000 и после него выводить количество нулей в конце данного факториала, а также время за которое исполняется программа
алгоритм должен выполниться быстрее чем приведенный ниже как минимум в 1.5 раза


Python 3 нужно написать программу которая будет вычислять факториал 100000 и после него выводить кол

Показать ответ
Ответ:
sashafedorishyn
sashafedorishyn
05.01.2021 22:43

import time

start_time = time.time()

y = int()

fct = int(1)

z = int(0)

for i in range(1, 100001):

   fct *= i

   y = i

   while ((y % 5) == 0):

       z += 1

       y /= 5

print(fct)

print(z)

print("--- %s seconds ---" % (time.time() - start_time))

input()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота