В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Гммммм
Гммммм
03.04.2023 08:01 •  Информатика

PYTHON 3 На вход программе подается натуральное число nn, а затем nn различных натуральных чисел, каждое на отдельной строке. Напишите программу, которая выводит наибольшее и второе наибольшее число последовательности.

Формат входных данных

На вход программе подаются натуральное число n 2n≥2, а затем nn различных натуральных чисел, каждое на отдельной строке.

Формат выходных данных

Программа должна вывести два наибольших числа, каждое на отдельной строке.

Sample Input 1:

5

1

2

3

4

5

Sample Output 1:

5

4

Sample Input 2:

8

9

7

5

4

3

2

78

1

Sample Output 2:

78

9

Sample Input 3:

13

1

2

3

5

8

233

13

21

34

377

55

89

144

Sample Output 3:

377

233

===

вот мой код

largest = -1

num = int(input())

for i in range(0,num):

num = int(input())

if num > largest:

largest = num

print(largest)

=

это отступы

максимальное я нашел а то что перед максимальным у меня не получается

Показать ответ
Ответ:
kasa0303
kasa0303
04.02.2021 18:40

mins = 9*99

maxs = -9*999

count = int(input())

if count < 2:

   print("Не может быть меньше двух")

else:

   for i in range(count):

       a = int(input())

       if a < mins:

           mins = a

       elif a > maxs:

           maxs = a

if count > 2:

   print(maxs)

   print(mins)

   

# такой же, но более памятозатратный.

# можно конечно оптимизировать, но для учебного варианта пойдёт

a = []

count = int(input())

if count < 2:

   print("Не может быть меньше двух")

else:

   for i in range(count):

       d = int(input())

       a.append(d)

if count > 2:

   print(max(a))

   print(min(a))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота