В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
glushkovanastya
glushkovanastya
27.01.2020 18:38 •  Информатика

PYTHON 3 Гринч, зашифровал все названия подарков, которые дети писали в письмах Деду Морозу. Начинал он шифровать с буквы, которая находится в середине названия подарка. Если название четной длины, то буква посередине считалась та, которая стоит левее из двух средних букв. Средняя буква выделена в следующих примерах: iphone, monitor. Если название подарка состоит из одной буквы, то, по определению выше, оно и будет его серединой.

Гринч шифровал каждое название следующим образом: он выписывал среднюю букву, затем удалял эту букву из названия и повторял процесс до тех пор, пока в названии есть хоть одна буква. Например, слово iphone он зашифрует в слово hopnie.

Вам задано слово s, зашифрованное название подарка Гринчем, а ваша задача — расшифровать его для Деда Мороза.

Входные данные

В первой строке следует целое положительное число n (1 ≤ n ≤ 2000) — длина зашифрованного названия подарка.

Во второй строке следует строка s длины n, состоящая из строчных букв латинского алфавита — зашифрованное название подарка.

Выходные данные

Выведите название подарка, которое зашифровал Гринч.

Показать ответ
Ответ:
Kristina17217
Kristina17217
28.03.2022 07:35

Тут четыре цикла, каждый из которых выполняет движение до конца (до тех пор, пока робот не достигнет стенки).

1) Нужно в уме представить клетки, в которые "упадут" роботы из всех начальных положений, если будут двигаться в первом направлении (вверх, до конца). Таких клеток окажется немного (см. рисунок 1).

2) Потом представляем, куда из этих клеток переместится робот при движении влево до конца. Таких клеток ещё меньше (см. рисунок 2).

3) Смотрим, куда попадём если вниз до конца. Останется одна клетка (см. рисунок 3).

4) И, двигаемся до конца вправо (см. рисунок 4).

Мы попадём в клетку E1.

Сюда будут попадать роботы из любого начального положения в этом лабиринте. Значит, единственная клетка, с которой робот может начать и в ней же закончить движение- это и есть клетка E1.


решить это задание. 1) Система команд исполнителя РОБОТ, «живущего» в прямоугольном лабиринте на кле
0,0(0 оценок)
Ответ:
НикитаГоровой
НикитаГоровой
27.02.2021 09:06

p = [1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 21]

q = [3, 6, 9, 12, 15, 18, 21, 24, 27, 30]

ans = 0

for x in range(30):

   if (x in p) and (x in q):

       ans += x

print(ans)

Объяснение:

Это логическое выражение, где переменными выступают выражения (x \in P), (x \in A) и (x \in Q). Обозначим их за p, a и q соответственно. Например, p=1, если x \in P, и 0 иначе. У нас получается следующее выражение:

(p \to a) \lor (\neg a \to \neg q)

Раскроем импликацию и получим:

\neg p \lor a \lor a \lor \neg q

Уберём повторяющуюся a. Наше финальное выражение:

\neg p \lor a \lor \neg q

Таким образом, выражение из условия будет истинно, если число не принадлежит P, или не принадлежит Q, или принадлежит A. Множество A наименьшего размера будет содержать все числа, которые не удовлетворяют условию \neg p \lor \neg q, то есть все числа, которые принадлежат и P, и Q.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота