В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Python 1. Напишите программу, которая заполняет массив из N = 8 элементов случайными числами в диапазоне [0,20], выводит его на экран, а затем меняет местами пары соседних элементов, кроме первого и последнего (2-й с 3-м, 4-й с 5-м и т.д.).
Пример:
Массив: 5 16 2 13 3 14 18 17
Реверс: 5 2 16 3 13 18 14 17

Показать ответ
Ответ:
kolafeoktistovp0aj9j
kolafeoktistovp0aj9j
12.04.2023 14:40
Начало:1.подойти к телефону,2.поднять трубку телефона,3.набрать номер друга,4.подождать пока друг поднимет трубку,5.поговорить с другом,6.поставить трубку на место,7.отойти от телефона. конец                                                                                                                                                                                                                             это линейный алгоритм.в линейном алгоритме шаги выполняются в той последовательности,в которой они записаны
0,0(0 оценок)
Ответ:
MAXIMUS111111111
MAXIMUS111111111
26.06.2021 13:26
Using System;

static void Main()
{
        int[] sourceArray = new int[] {3, 1, -4, -4, 65};                  //Исходный массив
        int[] newArray = new int[sourceArray.Length * 2];                  //Новый массив с максимальной нужной длиной
        int newArrayIndex = 0;                                             //Индекс для нового массива
        for (int i = 0; i < sourceArray.Length; i++)
        {
                newArray[newArrayIndex++] = sourceArray[i];
                if (i == sourceArray.Length - 1 || sourceArray[i] != sourceArray[i + 1])
                        newArray[newArrayIndex++] = 0;
        }
        for (int i = 0; i < newArrayIndex; i++)                            //Выводим новый массив на экран
                Console.Write(newArray[i] + " ");
        Console.ReadKey();
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота