В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Пусть задан массив из 20 элементов, содержащию информацию о 20 участниц конкурса красоты ( точнее, количество набранных ими очков). Призы выдаются обычно следующим образом: сначала 10-е место, затем 9-е, затем 8-е, и так до 1-го. А второй десяток остаётся по возрастанию. Составьте программу, которая распределит результаты по этому алгоритму и выведет их на экран. В C++

Показать ответ
Ответ:
eldaryuldashev
eldaryuldashev
14.09.2020 17:28

#include <iostream>

using namespace std;

#define ll long long

#define ld long double

signed main(){

   const ll n = 20;

   ll a[n];

   for(ll i = 0; i < n; i++)

       cin >> a[i];

   sort(a,a+n);

   ll cur_place = 10;

   for(ll i = 10; i < 20; i++){

       cout << cur_place <<"th place reached: " << a[i] << " scores" << "\n";

       cur_place--;

   }

   cur_place = 11;

   for(ll i = 0; i < 10; i++){

       cout << cur_place <<"th place reached: " << a[i] << " scores" << "\n";

       cur_place++;

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота