В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kluk12
kluk12
29.07.2022 16:02 •  Информатика

Пусть дано некоторое целое число. требуется составить программу, которая выводит на экран монитора сообщение о том, какое это число: положительное либо отрицательное. и если это число положительное, уменьшает его в 2 раза, в противном случае возводит его в квадрат.

Показать ответ
Ответ:
aru1608
aru1608
28.07.2020 10:57
Program a2;
var a,b:integer;
begin
 write('Введите целое числo');
 readln(a);
  if a > 0 then  begin
 b:=a div 2;                                   
  end
  else
 begin b:=a*a;
                 end;
  write ('b',b);
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота