В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nikitakuryan228
nikitakuryan228
19.04.2023 10:52 •  Информатика

Проверьте программы представленных задач, исправьте ошибки. 1. Напишите программу, которая выводит на экран 10 строк следующего содержания: «**++==++**».
Решение:
program for1;
var a:integer
begin
for i:=1 to 5 do
writeln('**++==++**');
end.

2. Напишите программу вывода квадратов первых десяти натуральных чисел.
Решение:
program for2;
var i, x: integer;
begin
for i:=1 to 10
begin
x:=x*x*x;
writeln( ' x ' );
end;
end.

3. Напишите программу нахождения суммы 1 + 1/2 + 1/3 +...(N слагаемых).
Решение:
program for3;
var i, n: integer;
s: string;
begin
write('n='); readln(n);
s:=10;
i:=1 to n
s:=s+1/i;
writeln('s=', s);
end.

Показать ответ
Ответ:
lisa2051
lisa2051
15.03.2021 16:33

Вопросы к уроку

На этом уроке мы на практике разберём: как составлять алгоритмы различных типов, а также как «читать» алгоритм по готовой блок-схеме.

Конспект

Составление линейных алгоритмов

На предыдущих уроках мы узнали, что такое алгоритм, какие бывают виды алгоритмов, и кто их исполняет.

Сегодня мы попрактикуемся в составлении алгоритмов. Это очень важные навыки. Мы уже неоднократно отмечали, что составить алгоритм, то есть объяснить другому, как выполнять те или иные задачи так, чтобы это было понятно каждому, - очень тяжело. Наша задача – научиться составлять алгоритмы для различных примеров, чтобы впоследствии, когда вы столкнётесь с необходимостью составлять алгоритмы для написания различных программ, это не составляло для вас особого труда.

Начнём мы с самых простых алгоритмов – линейных. Их составление, обычно, не вызывает особого труда. Однако, навыки составления таких алгоритмов чрезвычайно важны.

Пример 1. Составить алгоритм запуска программы Paint в ОС Windows 7.

Вспомним из курса информатики 5 класса порядок действий для запуска программы Paint.

Войти в меню «Пуск».

Войти в пункт «Все программы».

Войти в пункт «Стандартные».

Выбрать программу «Paint».

Данный алгоритм в виде блок-схемы имеет следующий вид:

Объяснение:

0,0(0 оценок)
Ответ:
Имом
Имом
29.01.2021 01:39

(Я зделал более сложную программу, но длинная она из-за того, что мне было лень переделать всё в цикл)

Объяснение:

from turtle import*

i=0

speed(0)

width(5)

fillcolor("yellow")

up()

goto(-300,-300)

down()

begin_fill()

forward(100)

left(90)

forward(50)

left(90)

forward(50)

goto(-300,-300)

end_fill()

while(i<4):

up()

goto((-200+i*100),-300)

down()

left(180)

begin_fill()

forward(100)

left(90)

forward(50)

left(90)

forward(100)

end_fill()

i=i+1

up()

goto(200,-300)

down()

begin_fill()

width(1)

right(90)

forward(50)

width(5)

right(90)

forward(50)

goto(300,-300)

goto(200,-300)

end_fill()

up()

goto(-250,-250)

down()

begin_fill()

forward(100)

left(90)

forward(50)

left(90)

forward(50)

goto(-250,-250)

end_fill()

i=0

while(i<3):

up()

goto((-150+i*100),-250)

down()

left(180)

begin_fill()

forward(100)

left(90)

forward(50)

left(90)

forward(100)

end_fill()

i=i+1

up()

goto(150,-248)

down()

begin_fill()

width(1)

right(90)

forward(48)

width(5)

right(90)

forward(50)

goto(250,-248)

end_fill()

up()

goto(-200,-200)

down()

begin_fill()

forward(100)

left(90)

forward(50)

left(90)

forward(50)

goto(-200,-200)

end_fill()

i=0

while(i<2):

up()

goto((-100+i*100),-200)

down()

left(180)

begin_fill()

forward(100)

left(90)

forward(50)

left(90)

forward(100)

end_fill()

i=i+1

up()

goto(100,-198)

down()

begin_fill()

width(1)

right(90)

forward(48)

width(5)

right(90)

forward(50)

goto(200,-198)

end_fill()

up()

goto(-150,-150)

down()

begin_fill()

forward(100)

left(90)

forward(50)

left(90)

forward(50)

goto(-250,-250)

end_fill()

i=0

while(i<1):

up()

goto((-50+i*100),-150)

down()

left(180)

begin_fill()

forward(100)

left(90)

forward(50)

left(90)

forward(100)

end_fill()

i=i+1

up()

goto(50,-148)

down()

begin_fill()

width(1)

right(90)

forward(48)

width(5)

right(90)

forward(50)

goto(150,-148)

end_fill()

up()

goto(-100,-100)

down()

begin_fill()

forward(100)

left(90)

forward(50)

left(90)

forward(50)

goto(-100,-100)

end_fill()

up()

goto(0,-98)

down()

begin_fill()

width(1)

right(90)

forward(48)

width(5)

right(90)

forward(50)

goto(100,-98)

end_fill()

up()

goto(-50,-50)

down()

begin_fill()

goto(0,0)

goto(50,-50)

end_fill()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота