В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
salamov1213
salamov1213
11.02.2020 02:12 •  Информатика

Программирование.язык паскаль. ,нужно нарисовать блок схемы и написать программы 1)дана строка и буква. определить сколько слов в строке начинается на эту букву.вывести эти слова. 2)составить программу,которая в заданном слове с дефисом меняет местами части до и после дефиса

Показать ответ
Ответ:
nlogvinova14
nlogvinova14
01.10.2020 16:51
2 задача
var   
   s,a,b:string;
begin     
   writeln('Введите слово: ');  readln(s);     
   b:=Copy(s,1,Pos('-',s)-1);     
   a:=Copy(s,Pos('-',s)+1,Length(s)-Length(b));     
   writeln(a,'-',b);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота