В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
danilpostnyh
danilpostnyh
27.01.2020 04:52 •  Информатика

ПРОГРАММИРОВАНИЕ решить задачу на C++/Python

G. Браконьеры
ограничение по времени на тест: 1.5 секунд
ограничение по памяти на тест: 256 мегабайт
ввод: стандартный ввод
вывод: стандартный вывод
Алиса и Боб — два браконьера, которые рубят лес.

Лес это набор (возможно пустой) деревьев. Дерево — это связный граф без циклов. Подвешенное дерево имеет специальную вершину — корень. Родителем вершины v называется следующая вершина на кратчайшем пути от v до корня. Детьми вершины v называются вершины, для которых v является родителем. Вершина называется листом, если у неё нет детей.

В этой задаче мы определим глубину вершины как количество вершин на простом пути от этой вершины до корня. Рангом дерева назовем минимальную глубину его листа.

Изначально дан непустой лес подвешенных деревьев. Алиса и Боб играют в игру на этом лесе. Они ходят по очереди, Алиса ходит первой. В начале каждого хода игрок выбирает дерево из леса. Далее игрок выбирает положительное целое число — глубину разреза, которая не превосходит ранга выбранного дерева. Затем игрок удаляет из дерева все вершины, чьи глубины меньше либо равны глубине разреза. Все остальные вершины разбиваются на набор подвешенных деревьев, корнем каждого становится вершина, имевшая наименьшую глубину в дереве до разреза. Все эти деревья добавляются в лес и игра продолжается.

Игрок проигрывает, если на момент начала его хода лес пуст.

Определите, может ли Алиса победить, если оба игрока играют оптимально.

Входные данные
Во входных данных находятся несколько наборов входных данных. В первой строке находится одно целое число t (1≤t≤5⋅105) — количество наборов входных данных. Далее следуют наборы входных данных.

Первая строка набора входных данных содержит одно целое число n (1≤n≤5⋅105) — суммарное количество вершин в деревьях изначального леса.

Вторая строка содержит n целых чисел p1,p2,…,pn (0≤pi≤n) — описание леса. Если pi=0, то i-я вершина дерева является корнем, иначе pi является родителем вершины i. Гарантируется, что p задает корректный лес подвешенных деревьев.

Гарантируется, что сумма значений n по всем наборам входных данных не превосходит 5⋅105.

Выходные данные
Для каждого набора входных данных выведите «YES» (без кавычек), если Алиса может победить, иначе выведите «NO» (без кавычек). Вы можете выводить каждую букву в любом регистре.

Пример
входные данные
4
4
0 1 0 3
7
0 1 2 0 4 5 6
4
0 1 1 2
7
0 1 1 2 2 3 3
выходные данные
NO
YES
NO
YES

Показать ответ
Ответ:
LeraLis201
LeraLis201
09.01.2020 00:21

1.

program asd;
uses crt;
var
a: array[1..10] of integer;
i:integer;
sum:integer;
begin
writeln('Введите 10 цифр по очереди');
for i:=1 to 10 do
begin
readln(a[i]);
if (a[i]>7) then begin a[i]:=7; sum:=sum+1; end;
end;

writeln(' ',sum);

end.

 

2. смысл задания? 10/2=5 или индексами ты имела ввиду значениями? 

3.
program asd;
uses crt;
var
a: array[1..10] of integer;
i:integer;
naib:integer;
begin
writeln('Введите 10 цифр по очереди');
for i:=1 to 10 do
begin
readln(a[i]);
if (a[i]>naib) then naib:=a[i];
end;

writeln(' ',naib);

end.

0,0(0 оценок)
Ответ:
TwistChanel
TwistChanel
20.06.2021 03:57
Const
  gl = ['а', 'е', 'ё', 'и', 'о', 'у', 'ы', 'э', 'ю', 'я'];

var
  w1, w2: string;
  m: set of char;
  c: char;
  i: integer;

begin
  Writeln('Введите первое "слово"');
  Readln(w1);
  Writeln('Введите второе "слово"');
  Readln(w2);
  m := [];
  w1 := LowerCase(w1);w2 := LowerCase(w2);
  for i := 1 to length(w1) do
    if w1[i] in gl then Include(m, w1[i]);
  for i := 1 to length(w2) do
    if w2[i] in m then Exclude(m, w2[i]); 
  Writeln('Гласные, присутствующие в первом слове и отсутствующие во втором:');
  foreach c in m do Write(c, ' ');
  Writeln
end.

Тестовое решение:
Введите первое "слово"
Дай, Джим, на счастье лапу мне!
Введите второе "слово"
Сергей Есенин
Гласные, присутствующие в первом слове и отсутствующие во втором:
а у
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота