В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Chara5
Chara5
10.01.2023 00:17 •  Информатика

Программирование на С++ Описать класс «множество», позволяющий выполнять основные операции — добавление и удаление элемента, пересечение, объединение и разность множеств.
Написать программу, демонстрирующую работу с этим классом. Программа должна содержать меню, позволяющее осуществить проверку всех методов класса.

Показать ответ
Ответ:
tomatik47
tomatik47
18.03.2020 15:57
Program test;
uses utils;
var
  n,i,sum,time:longint;
  flag:boolean;
begin
    readln(n);
    if n<2 then flag:=false;{Единица - не простое число}
    if n=2 then flag:=true;{2 - простое}
    if (n>2) and (n mod 2 <> 0) then begin{ после двойки простые числа только нечетные}
      for i:=1 to n do begin{проверяем что бы было только 2 делителя}
        sum:=sum+1;
      end;
      if sum=2 then flag:=true;
    end
    else flag:=false;
    if flag then writeln('Число простое') else writeln('Число НЕ простое');
    time:=milliseconds;
    writeln('Времени затрачено ',time:10,' ms.');
end.
Все проверки сделаны для сокращения времени работы программы.
0,0(0 оценок)
Ответ:
McVano
McVano
26.12.2022 09:48
На pascal abc net
program test;
type realarray = array of real;
var
  step:real;
  a:realarray;
  i,n,s1,s2,s3,s4:integer;
begin
  write('Введите количество членов последовательности: ');
  readln(n);
  step:=1/n;
  setlength(a,n);
  a[0]:=0;
  for i:=1 to n-1 do a[i]:=a[i-1]+step;
  for i:=0 to n-1 do begin
    if a[i]<0.25 then s1:=s1+1;
    if (a[i]>=0.25) and (a[i]<0.5) then s2:=s2+1;
    if (a[i]>=0.5) and (a[i]<0.75) then s3:=s3+1;
    if a[i]>=0.75 then s4:=s4+1;
  end;
  writeln('На промежутке [0,0.25)  -  ',s1);
  writeln('На промежутке [0.25,0.5)  -  ',s2);
  writeln('На промежутке [0.5,0.75)  -  ',s3);
  writeln('На промежутке [0.75,1)  -  ',s4);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота