В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dgbimv
dgbimv
09.03.2023 20:13 •  Информатика

Программирование на Python. Звездный треугольник

Дано нечетное натуральное число nn. Напишите программу, которая печатает равнобедренный звездный треугольник с основанием, равным nn в соответствии с примером:

*
**
***

***
**
*

Формат входных данных
На вход программе подается одно нечетное натуральное число.

Формат выходных данных
Программа должна вывести треугольник в соответствии с условием.

Примечание. Используйте вложенный цикл for!

Показать ответ
Ответ:
soykaalayaovpiyg
soykaalayaovpiyg
15.10.2020 13:33

nn = int(input())

x = ''

for i in range(1, nn // 2 + 2):

   x = ''

   for z in  range(i): x += '*'

   print(x)

mas = [None] * (nn // 2)

m = 0

for i in range(0, nn // 2): mas[i] = '*' * (i + 1)

for i in range(0, len(mas)):

   m = len(mas) - i - 1

   print(mas[m])

можно было-бы сделать все в 3 строки, но чего-то нельзя в for сделать шаг в обратную сторону

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота