В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
чивапчич
чивапчич
23.01.2020 02:06 •  Информатика

Программирование на Python. Создайте программу простую, с циклом while.
Одинаковые цифры

Дано натуральное число. Напишите программу, которая определяет, состоит ли указанное число из одинаковых цифр.

Формат входных данных 
На вход программе подается одно натуральное число.

Формат выходных данных
Программа должна вывести «YES» если число состоит из одинаковых цифр и «NO» в противном случае.

Показать ответ
Ответ:
Abdueva
Abdueva
15.10.2020 13:26

--- Python 3.8.3 ---

#1 "Как надо" (С While)

def IsNumberSingledigit(number):

   lastDigit = number % 10

   temp = lastDigit

   flag = True  

   while number > 0:

       lastDigit = number % 10

       if not temp == lastDigit: flag = False  

       temp = lastDigit

       number //= 10

   return flag

def main():

   print(IsNumberSingledigit(int(input(

   

if __name__ == "__main__":

   main()

#2 Как стоило бы в подобном случае

number = int(input()) #Представляем число как строку

print(True if (len(set(str(number))) == 1) else False)

P.S Приведение сначала к числу а потом обратно к строке нужно для уверенности, что мы работаем именно с числом, а не с "".

Объяснение:

0,0(0 оценок)
Ответ:
elenakopylova7
elenakopylova7
15.10.2020 13:26

number = list(input())

a = number[0]

b = 1

i = 1

while i != len(number):

   if(a == number[i]):

       b += 1

   i += 1

if(b == len(number)):

   print('YES')

else:

   print('NO')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота