В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
matvee1
matvee1
25.06.2020 06:25 •  Информатика

Программирование на Python. Напишите программу-калькулятор: пользователь вводит 5 целых чисел, после чего программа должна вывести их произведение. Чтобы перемножать числа было не слишком легко, нули не учитывайте.
Гарантируется, что не все введённые числа — нули.

Показать ответ
Ответ:
Belka172
Belka172
23.01.2021 15:41

print("Введите 5 чисел, каждое число с новой строки ")

x = [float(input()) for i in range(5)]

pr = 1

for i in range(len(x)):

   if x[i] != 0:

       pr *= x[i]

print(pr)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота