Программирование C++ Автобусные остановки расположены через каждые K метров от начала улицы, то есть на расстоянии 0, K, 2K, 3K и т.д. Метров от начала. Света от начала улицы N метров, после чего устала и захотела сесть на автобус Определите, сколько метро нужна пройти Свете до ближайшей остановки
Программа поиска элемента в произвольном массиве: const n=10; var a:array[1..n+1] of integer; p,i:integer; begin Randomize; writeln('Исходный массив:'); for i:=1 to n do begin a[i]:=random(21); write(a[i]:4); end; writeln; write('p = '); readln(p); a[n+1]:=p; i:=1; while a[i]<>p do i:=i+1; if i<=n then writeln('Искомый элемент найден, его номер = ',i) else writeln('Искомый элемент не найден'); end.
Пример 1: Исходный массив: 7 17 16 13 0 1 19 20 12 5 p = 13 Искомый элемент найден, его номер = 4
Пример 2: Исходный массив: 20 4 5 12 14 10 11 16 18 20 p = 15 Искомый элемент не найден
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016 type tBook=record author:string[30]; naim:string[50]; pages:integer; godizd:integer end; begin var f:file of tBook; Rewrite(f,'books.dat'); Writeln('Ввод данных по книгам'); var s1,s2:string; var i1,i2:integer; var book:tBook; repeat s1:=ReadlnString('Автор или * для окончания ввода:'); if s1<>'*' then begin s2:=ReadlnString('Название книги:'); i1:=ReadlnInteger('Количество страниц:'); i2:=ReadlnInteger('Год издания:'); (book.author,book.naim,book.pages,book.godizd):=(s1,s2,i1,i2); Write(f,book) end until s1='*'; Writeln('*** Ввод завершен ***'); f.Close end.
Тестовое решение Ввод данных по книгам Автор или * для окончания ввода: Жюль Верн Название книги: 80 тысяч километров под водой Количество страниц: 573 Год издания: 1951 Автор или * для окончания ввода: Сергей Лукьяненко Название книги: Дозор Количество страниц: 934 Год издания: 2004 Автор или * для окончания ввода: Жюль Верн Название книги: Властелин мира Количество страниц: 104 Год издания: 2011 Автор или * для окончания ввода: * *** Ввод завершен ***
2. Программа для выборки
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016 type tBook=record author:string[30]; naim:string[50]; pages:integer; godizd:integer end; begin var f:file of tBook; Reset(f,'books.dat'); var s:=ReadlnString('Автор книги:'); var y:=Readinteger('Год издания, не ранее:'); var k:=0; var book:tBook; while not f.Eof do begin Read(f,book); if (book.author=s) and (book.godizd>=y) then begin Writeln(book); Inc(k) end; end; if k=0 then Writeln('Таких книг не найдено'); f.Close end.
Тестовое решение Автор книги: Жюль Верн Год издания, не ранее: 2005 (Жюль Верн,Властелин мира,104,2011)
const n=10;
var a:array[1..n+1] of integer;
p,i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21);
write(a[i]:4);
end;
writeln;
write('p = '); readln(p);
a[n+1]:=p;
i:=1;
while a[i]<>p do i:=i+1;
if i<=n
then writeln('Искомый элемент найден, его номер = ',i)
else writeln('Искомый элемент не найден');
end.
Пример 1:
Исходный массив:
7 17 16 13 0 1 19 20 12 5
p = 13
Искомый элемент найден, его номер = 4
Пример 2:
Исходный массив:
20 4 5 12 14 10 11 16 18 20
p = 15
Искомый элемент не найден
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
type
tBook=record
author:string[30];
naim:string[50];
pages:integer;
godizd:integer
end;
begin
var f:file of tBook;
Rewrite(f,'books.dat');
Writeln('Ввод данных по книгам');
var s1,s2:string;
var i1,i2:integer;
var book:tBook;
repeat
s1:=ReadlnString('Автор или * для окончания ввода:');
if s1<>'*' then begin
s2:=ReadlnString('Название книги:');
i1:=ReadlnInteger('Количество страниц:');
i2:=ReadlnInteger('Год издания:');
(book.author,book.naim,book.pages,book.godizd):=(s1,s2,i1,i2);
Write(f,book)
end
until s1='*';
Writeln('*** Ввод завершен ***');
f.Close
end.
Тестовое решение
Ввод данных по книгам
Автор или * для окончания ввода: Жюль Верн
Название книги: 80 тысяч километров под водой
Количество страниц: 573
Год издания: 1951
Автор или * для окончания ввода: Сергей Лукьяненко
Название книги: Дозор
Количество страниц: 934
Год издания: 2004
Автор или * для окончания ввода: Жюль Верн
Название книги: Властелин мира
Количество страниц: 104
Год издания: 2011
Автор или * для окончания ввода: *
*** Ввод завершен ***
2. Программа для выборки
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
type
tBook=record
author:string[30];
naim:string[50];
pages:integer;
godizd:integer
end;
begin
var f:file of tBook;
Reset(f,'books.dat');
var s:=ReadlnString('Автор книги:');
var y:=Readinteger('Год издания, не ранее:');
var k:=0;
var book:tBook;
while not f.Eof do begin
Read(f,book);
if (book.author=s) and (book.godizd>=y) then begin
Writeln(book);
Inc(k)
end;
end;
if k=0 then Writeln('Таких книг не найдено');
f.Close
end.
Тестовое решение
Автор книги: Жюль Верн
Год издания, не ранее: 2005
(Жюль Верн,Властелин мира,104,2011)