В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ruki2233
Ruki2233
18.06.2020 19:05 •  Информатика

Программа в языке Си Написать программу, выделив под массив динамически память. Обращаться к элементам массива необходимо используя указатель. Ограничения на функцию main 50 строк, на пользовательские функции – 30.
--Заполнить элементы двумерного массива натуральными числами. Из каждой нечётной (нумерация начинается с 0) строки удалить минимальный элемент.--
Заранее Буду рад любой

Показать ответ
Ответ:
SaviRay
SaviRay
08.01.2021 10:03
Program CrazyCoder;

var i,n:byte;
k:integer;
a:array [1..10] of integer;
begin         
randomize;      
writeln('Исходный массив');      
for i:=1 to 10 do          
begin              
a[i]:=random(21)-10;              
write(a[i],' ');          
end;      
writeln;      
write('Введите кол-во смещений: ');      
read(n);      
repeat            
k:=a[2];            
for i:=2 to 9 do                
a[i]:=a[i+1];            
a[10]:=k;            
n:=n-1;      
until n=0;      
writeln('Результат:');      
for i:=1 to 10 do          
write(a[i],' ');      
writeln;
end.
0,0(0 оценок)
Ответ:
Waz4
Waz4
10.06.2022 04:44
Const   n = 50; // количество чиселvar   k: array [1..n] of integer;   i, j, n1, n2, minr, a, b: integer; begin   writeln(n, ' ', ': d');   a : = random(1000);   b : = random(1000);   minr : = 10000;   for i : = 1 to n do       k[i] : = a + random(b);   for i : = 1 to n do       for j : = 1 to n do           if ((abs(k[i] - k[j])) < minr) and (k[i] < > k[j]) then           begin               minr : = abs(k[i] - k[j]);               n1 : = i;               n2 : = j;           end;   writeln(n1, ' ', n2); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота