В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
31Maks31
31Maks31
12.11.2020 22:38 •  Информатика

Программа в с++ 1. описать класс с именем marsh, содержащую следующие, поля: • begst — название начального пункта маршрута; • term — название конечного пункта маршрута; • numer — номер маршрута. 2. написать программу, выполняющую следующие действия: • ввод с клавиатуры данных в массив trafic, состоящий из 3 элементов типа marsh; • вывод на экран информации о маршруте, номер которого введен с клавиатуры; • если таких маршрутов нет, выдать на дисплей соответствующее сообщение.

Показать ответ
Ответ:
solopova08
solopova08
20.08.2020 14:38
/*
1. Описать класс с именем MARSH, содержащую следующие, поля:
• BEGST — название начального пункта маршрута;
• TERM — название конечного пункта маршрута;
• NUMER — номер маршрута.
2. Написать программу, выполняющую следующие действия:
• ввод с клавиатуры данных в массив TRAFIC, состоящий из 3 элементов типа MARSH;
• вывод на экран информации о маршруте, номер которого введен с клавиатуры;
• если таких маршрутов нет, выдать на дисплей соответствующее сообщение.
*/

#include <iostream>
using namespace std;

class MARSH
{
public:
string BEGST, TERM, NUMER;

MARSH(string b, string t, string n)
: BEGST(b), TERM(t), NUMER(n)
{
}

MARSH() {}

void info() {
cout << "Маршрут №" << NUMER
<< " (" << BEGST << '-'
<< TERM << ')';
}
};

int main()
{
MARSH TRAFFIC[3];
string b, t, n;
for (int i = 0; i < 3; i++) {
cout << "Ввод данных для маршрута " << i << ':' << endl;
cout << "Название начального пункта маршрута: ";
cin >> b;
cout << "Название конечного пункта маршрута: ";
cin >> t;
cout << "Номер маршрута: ";
cin >> n;
cout << endl;
TRAFFIC[i] = MARSH(b, t, n);
}
cout << endl << "Введите номер маршрута: ";
cin >> n;
MARSH m;
for (int i = 0; i < 3; i++) {
m = TRAFFIC[i];
if (m.NUMER == n) {
m.info();
return 0;
}
}
cout << "Нет маршрута с таким номером!" << endl;
return 1;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота