В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
12АлИк34
12АлИк34
27.12.2022 08:56 •  Информатика

Программа в паскале, . даны два действительных числа. составьте программу, которая меньшее из них заменяет их полусуммой, а большее - их произведением.

Показать ответ
Ответ:
2001snk
2001snk
02.10.2020 06:48
Program gg;
var x,y,c:real;
begin
 read(x,y);
if x>y then
     begin
      c:=y;
      y:=(x+y)/2;
      x:=x*c;
     end
else
   begin
      c:=x;
      x:=(x+y)/2;
      y:=y*c;
     end;
write('x=',x,'y=',y)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота