В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
veronikatulene
veronikatulene
06.10.2021 03:03 •  Информатика

Программа в pascalabc даны две точки в плоской прямоугольной системе координат. напишите программу, которая позволяет вводить с клавиатуры координаты точек, вычислять расстояние их до начала координат и определять - которая из точек (первая или вторая) находятся ближе к началу координат.

Показать ответ
Ответ:
unicorn2837
unicorn2837
05.10.2020 09:45
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

type
  Point=(real,real);

procedure GetPoint(var Q:Point);
begin
  var a,b:real;
  Write('Введите координаты точки: '); Read(a,b);
  Q:=(a,b)
end;

function Distance(a:Point):=Sqrt(Sqr(a[0])+Sqr(a[1]));

begin
  var a,b:(real,real);
  GetPoint(a);
  GetPoint(b);
  var d1:=Distance(a);
  var d2:=Distance(b);
  if d1<d2 then Writeln('Первая точка ближе')
  else
    if d1>d2 then Writeln('Вторая точка ближе')
    else Writeln('Точки равноудалены')
end.

Пример
Введите координаты точки: 13.7 -11.25
Введите координаты точки: 18 12.4
Первая точка ближе
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота