В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ElenaAlrman2707
ElenaAlrman2707
16.04.2020 05:46 •  Информатика

Программа:
сравнить первую и последнюю строку в целочисленной квадратной матрицы поэлементно​

Показать ответ
Ответ:
iriska198501
iriska198501
15.06.2022 18:10

есть массив a из n чисел, к каждому числу массива жарасхан должен применить лишь одну операции  

1) добавить к числу один

2) отнять от числа один

3) добавить к числу ноль

к каждому элементу массива нужно применить одну их трех операции так, чтоы после применения операций ко всем элементам массива, количество одинаковых чисел в массиве стало максимальным.  

формат входных данных:

в первой строке входных данных дано одно целое число n - размер массива. во второй строке входных данных даны элемента массива a;

формат выходных данных:  

выведите одно целое число - максимальное количество одинаковых чисел в массиве после применения операций.

пример:

входные данные:  

7

3 1 4 1 5 9 2

выходные данные:  

4

замечание: в первом тесте можно изменить массив в такой вид: 2,2,3,2,6,9,2

0,0(0 оценок)
Ответ:
Hasky12
Hasky12
19.03.2022 12:14

исходный код на языке программирования pascal

const n = 10;

var

    a: array[1..n] of integer;

    i: byte;

    avrg: real;

    sum: integer;

begin

    randomize;

    for i: =1 to n do a[i]: =random(50)+1;

    sum : = 0;

    for i: =1 to n do sum : = sum + a[i];

    avrg : = sum/n;

   

    // весь массив

    for i: =1 to n do write(a[i]: 3);

    writeln;

   

    writeln('среднее арифм.: ',avrg: 4: 2);

   

    // больше avrg    

    for i: =1 to n do if a[i]< avrg then write(a[i]: 3);

    writeln;

end.

пример(ы) выполнения программы на языке pascal

13 23 45   2   9 28 47 30 18 12

среднее арифм.: 22.70

13   2   9 18 12

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота