В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
никнейм85
никнейм85
27.06.2020 19:15 •  Информатика

Программа - Паскаль

Задание 1. Вычислите:
а) t and (p mod 2 = 0), при t =true, p =231;
б) (2*x * y div 5>10) or (y>4*x), при х =3, у =10;
в) (x * y mod 3=0) and (y г) not a or (not b), при a = false, b = true.
д) not(a or b ) and not a; при а = true и b = false.

Задание 2. Запишите условное выражение:
а) не нулевое число а – положительно;
б) целое k делится на 7;
в) х лежит вне отрезка [ 0,1];
г) х принадлежит отрезку [2,5] или [-1,1];
в) х лежит вне отрезков [2,5] или [-1,1];
д) целые n и k имеют одинаковую четность;

Задача 1. Машина выехала из пункта А в пункт В, между которыми Sкм. Машина двигалась с постоянной скоростью V и остановилась через t часов. Напишите программу, которая по введенным S, V, t определяет положение машины относительно пункта В: не доехала, приехала, проехала.

Задача 2. Даны величины градусных мер углов треугольника a, b, c. Определите какой это треугольник: прямоугольный, тупоугольный, остроугольный.

Показать ответ
Ответ:
dvortrans
dvortrans
27.03.2020 07:17
//Блок-схемы в приложении
//Pascal ABC.NET v3.0 сборка 1111

//1
Var
 a,p,s:real;
begin
readln(a);
p:=a*4;
s:=a*a;
writeln('P=',p);
writeln('S=',s);
end.

//2
Var
 a,b:integer;
begin
 read(a,b);
 if a>b then writeln(b);
 if a=b then writeln('=');
 if a<b then writeln(a);
end.

{На этом и закончу всем, кто когда либо и чем либо поддерживал данный проект. Думаю, он ещё многим послужит в критический момент. И я говорю не только про "списать домашку". Счастливо оставаться, господин Alviko. Может, ещё увидимся.
Ваш, Глеб 'I3artle' Косырев}
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
0,0(0 оценок)
Ответ:
Леночка200603
Леночка200603
17.04.2022 07:16
2^n в двоичной системе - это 1 и n нулей после неё. Например, 2^5(10) = 100000(2)
Приведём все степени к основанию 2

2^3702-2^468+2^1620-108

-108 можно представить как -128 + 16 + 4

2^3702-2^468+2^1620-2^7 + 2^4 + 2^2

Теперь выстраиваем степени в порядке убывания:

2^3702+2^1620-2^468-2^7 + 2^4 + 2^2

В выражении два вычитания подряд, избавимся от этого, заменив -2^468 на -2^469 + 2^468

2^3702+2^1620 -2^469+2^468-2^7 + 2^4 + 2^2

2^3702 - 1 единица
2^4 - 1 единица
2^2 - 1 единица

Количество единиц в вычитаниях будет равно разнице степеней. Например 1000000-100=1111

2^1620 -2^469 - количеств единиц 1620-469 = 1151
2^468-2^7 - количество единиц 468-7 = 461
Общее количество единиц равно 3+1151+461 = 1615
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота