В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Программа паскаль дано трехзначное число. напишите программу, которая определяет: является ли число перевертышем, т.е числом, десятичная запись которого читается одинаково слева направо и справа налево пример входных данных: 122, 121, 222 пример выходных данных: нет, перевертыш, перевертыш

Показать ответ
Ответ:
milenavoskanya
milenavoskanya
11.06.2020 13:23

var
  c, f, First, count:integer;
begin
  write('c = ');
  readln(c);
  f := c;
  while (f div 10 > 0) do
  begin
    First := f div 10;
    count := 1;
    while (First div 10 > 0) do
    begin
      First := First div 10;
      Inc(count);
    end;
    if First <> f mod 10 then
    begin
      writeln('No');
      readln;
      Exit;
    end;
    
    while count > 0 do
    begin
      First := First * 10;
      dec(count);
    end;
    f := f - First;
    f := f div 10;
  end;
  writeln('Changeling');
  readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота